[RndTbl] Data recovery

John Lange john.lange at bighostbox.com
Thu Dec 18 23:06:19 CST 2003

I have a hard drive that sort of died recently. For the most part it was
working normally but whenever I tried to "cd /" it would stall for a
long period of time. This got worse and worse until I finally made a
fatal mistake.... Not suspecting the drive was the problem and in a
moment of weakness I decided to reboot to try and fix the problem... It
never worked again...

I will attribute my poor judgement to having spent so much time in the
past working with "other" OSes where rebooting is your main
trouble-shooting tool. Sometimes you have uncontrolled flash-backs and
fall into old habits...

That being said, while I do have backups of all my most critical items
there was some other things I wouldn't mind recovering if possible.

The drive is still recognized in the BIOS etc. but it simply won't mount
under linux. Error is:

mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
       or too many mounted file systems

I've also tried mount with the "mount -o sb=xxx" option specifying some
alternative superblocks as determined by calling "mke2fs -n /dev/hdc1"
all to no avail.

Seems likely that the drive is 100% dead at this point but if anyone has
any tricks they could pass along I'd like to give them a whirl. I didn't
find much by the way of google.

Very much appreciate if anyone has any ideas.

On an entirely related note, does anyone have a good script (possibly
using rsync) for keeping files up-to-date between a desktop and a laptop
by way of a central server ?


John Lange
(204) 885 0872

More information about the Roundtable mailing list