[RndTbl] no routing entry for loopback

Gilles Detillieux grdetil at scrc.umanitoba.ca
Wed Nov 23 13:10:04 CST 2005

Dan Martin wrote:
> I have installed Fedora Core 4 on my firewall machine.  My networked 
> machines can browse the web, but I cannot access the loopback device, 
> eg, for SWAT configuration.
> ifconfig lo
> shows the loopback interface to be UP and RUNNING at inet addr
> ping localhost
> results in 100% packet loss
> The routing tables do not show a loopback entry, and if I try to add one 
> I get errors.
> Can anyone tell me what's going on?

Not entirely, but here's a bit of info that might help.  I just did a 
"netstat -r" on Red Hat 9, FC1, FC3 and FC4.  On RH9 & FC1, "lo" appears 
in the routing table output by netstat, while on FC3 & 4 it doesn't. 
Maybe it's a 2.6 kernel thing, but for whatever reason it seems "lo" 
doesn't need to be in the routing table for FC3 & 4.  I tried "ping 
localhost" on 2 different FC4 systems, though, as well as 1 FC3 system, 
and all worked fine.  They all have a fairly default configuration of 
iptables on them, as setup by system-config-securitylevel.

It might be worth a look at your own iptables configuration to see if 
something is amiss there, especially if you're running a non-standard 
(from a RH/Fedora perspective) setup.

Gilles R. Detillieux              E-mail: <grdetil at scrc.umanitoba.ca>
Spinal Cord Research Centre       WWW:    http://www.scrc.umanitoba.ca/
Dept. Physiology, U. of Manitoba  Winnipeg, MB  R3E 3J7  (Canada)

More information about the Roundtable mailing list