[RndTbl] Samba problem - network name not found

Dan Martin ummar143 at cc.umanitoba.ca
Wed Nov 30 14:01:04 CST 2005

I have been playing with Samba 3 on FC4 for over 3 days now, and it's 
starting to get not fun.

Samba appears to be up and running and the network is functional.  When 
I browse the network on my Windows machines (one is Win 2000 pro the 
other is NT4) I am prompted for a username/password, then the server 
shows on the network.  I can open its folder, and I can browse a tmp 
share inside (path /tmp) subject to the permissions of the subfolders.

When I try to access the home folder named "user" I get the error
\\Linuxserver\user is not accessible.  The network name cannot be found.

It appears that authentication is working, as I can login at the prompt, 
and the subfolder representing the home directory is named after the 
user.  Permissions under Linux should not be an issue, since I have 
granted universal access to /home and all subdirectories.  If I try to 
browse folders that I do not have access to, I get a different error - 
access denied.

Since the default mapping of the [homes] share did not seem to work, I 
have even tried setting the smb.conf parameter
to no avail.

I have tried numerous other things, and a Google search turned up dozens 
of dead ends.

Does anyone have ideas re
1)  the above problem
2)  how to 'flush the cache' so that I don't have to log on and off on 
Windows every time I try a change in Samba
3)  how to determine on the Linux machine which windows user is 
accessing from the network so I can confirm authentication is correct 
(like a 'who' command for Samba)


Dr. Dan Martin, MD, CCFP, BSc, BCSc (Hon)

GP Hospital Practitioner
Computer Science grad student
ummar143 at cc.umanitoba.ca
(204) 831-1746
answering machine always on

More information about the Roundtable mailing list