[RndTbl] data recovery

Adam Thompson athompso at athompso.net
Tue Sep 9 00:24:38 CDT 2014

Intel-based Macs do not have a PC BIOS, which is what handles keyboard I/O in DOS (and, generally, in real mode no matter what OS).
The iMac (et. al.) do have OpenFirmware and/or EFI, which handles the booting.  OF has its own USB class drivers, which the OS must then supplant during its boot sequence.

Take the drive to an actual PC with a SATA (or IDE, if applicable) port and boot diags there.  Or buy one of the better Mac disk repair utilities.  Or just pay Trevor to scan the drive for you, even if it is HFS+.


On September 8, 2014 11:52:31 PM CDT, Robert Dyck <rbdyck2 at shaw.ca> wrote:
>--- Trevor Cordes wrote:
>> In theory an Intel Mac should be able to boot normal x86 boot 
>> CDs for disk diags.  Unless the Mac BIOS does something 
>> stupid to make that impossible (wouldn't surprise me).  
>> You'll have to ask/google Mac people.
>I've never been able to get it to work. When I insert Memtest86+ v4.10,
>it does work. However, keyboard does not respond. Since this program
>starts right into its diagnostic, that isn't a problem. But the eject
>button on they keyboard does eject the CD.
>For hard drive diagnostics, I use Hiren. But that has never worked on
>Intel Mac. Hiren has multiple tools, and I tried Hiren version 9.9,
>13.1, and 15.2; each time the iMac just ejects the disk. I also burnt a
>CD of SeaTools for DOS v2.23, and a disk for SeaTools for DOS v1.10PH,
>and one for Hitachi Drive Fitness Test, but the iMac ejects those too.
>> My fave utility for 
>> this is UBCD which has all the mfr's diags on one disc that 
>> manages to boot on more systems than the originals!
>I have a copy of UBCD v4.1.1 and tried it on my iMac as I type this.
>(24-inch mid 2007) It was able to start, and did respond to the
>keyboard. Until I started SeaTools for DOS v1.09. It showed the legal
>disclaimer, but when I tried to type "Y" to accept, it froze. Salvation
>HDD Scan & Repair V3.0 froze on "Loading". Western Digital Data
>Lifeguard Diagnostic V4.15, V5.04f, and V11.2 all froze on "Loading".
>> > Can you do this
>> > through USB?
>> No.  Diags don't run through USB.
>Perhaps this is part of the problem. Intel iMacs do not have PS/2. I
>checked Wikipedia, every model of iMac back to the first G3 in 1999 has
>been USB only. Power Mac built in year 2000 was the last to use
>mini-DIN-8 for keyboard. They never used PS/2 (mini-DIN-6).
>Rob Dyck
>Roundtable mailing list
>Roundtable at muug.mb.ca

Sent from my Android device with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.muug.mb.ca/pipermail/roundtable/attachments/20140909/39abd48d/attachment.html>

More information about the Roundtable mailing list