[RndTbl] LibreNMS installation not working as it should

Gilbert E. Detillieux gedetil at cs.umanitoba.ca
Tue May 4 15:21:23 CDT 2021

Hi all.  May the Fourth be with you!  :)

I've run into a problem with an installation of LibreNMS on a system at 
work.  I've carefully followed the instructions here...


... for a Debian 10 system, with the occasional peeking at the Ubuntu 20 
installation instructions (since I wanted to use an Apache server 
already on that host, rather than follow the nginx-based install, which 
was the only option they showed for Debian 10).

When I run the validate.php script from the command line, everything 
looks fine.  When I run the validate under the web interface, it's all 
fine too, except after a day or more, when it complains under Updates 
that the install is over 24 hours out of date.  The curious thing is I 
didn't change the default setting for updates, so it should be 
automatically updating.  (That's only the first problem, though...)

When I add a device, it does the discovery, but the results seem 
incomplete.  For example, I don't see any of the network ports, and most 
of the other things that should be auto-discovered aren't.  I've tried 
this discovery on both a Cisco switch stack, and a Linux host, with the 
same lack of results.  (That's problem #2.)

I've also manually added in a bunch of the Apps on one Linux host (an 
RHEL clone), to monitor particular services.  I've done all the SNMP 
setup on that host to have the "extend" scripts run for the Apps I want, 
following these instructions...


... and I've tested that with snmpbulkwalk, to make sure they're 
producing output.  (In some cases, that took some digging through the 
scripts, and making sure paths were correct and additional software was 
set up, since the instructions above weren't always complete.)

However, when I try to view the pages for those Apps in LibreNMS, I get 
either broken image icons, or a place-holder image that says "Error 
Drawing Graph".  (This is problem #3.)

I've searched online for this last problem, but the proposed solutions 
I've found are mostly red herrings, or not applicable in my case.  I 
haven't found anything useful.

Anyone else here played around with LibreNMS?  (I know Adam has...)

If so, any ideas what might be causing any of the problems I've 
mentioned above?  Any tips for better setup documentation to follow than 
the "official" ones I have?  (There were details missing about 
particular Apps, so maybe the Install instructions also are missing 

BTW, I have Netdisco running on the same Debian host as LibreNMS, and it 
has no trouble getting information from the other devices via SNMP. 
(I've also got MRTG on another host, and it also has been working fine 
for years, querying the same devices I'm trying under LibreNMS.)


Gilbert E. Detillieux        E-mail:  <gedetil at cs.umanitoba.ca>
Dept. of Computer Science    Web:     http://cs.umanitoba.ca/~gedetil/
University of Manitoba
Winnipeg MB CANADA  R3T 2N2

More information about the Roundtable mailing list