[RndTbl] Fix for yum "Error: database disk image is malformed"

Gilbert E. Detillieux gedetil at cs.umanitoba.ca
Thu Dec 11 14:55:10 CST 2014

On one of my RHEL 6 compatible systems, I ran out of space on /var, and 
after clearing space, yum kept throwing the above error message.  After 
doing a Google search on the error, various suggestions were tried...

1. "yum clean all" (and variations on that to clear certain parts of the 
cache) didn't fix the problem.

2. "yum history new" also didn't help.

3. "rpm --rebuilddb" also didn't help.

Finally, after finding this posting...


... and looking at the bottom of the comment section, I found this 

4. "yum makecache" did the trick!

Here I thought that running a "yum update" after "yum clean dbcache" or
"yum clean all" would rebuild everything it needed, but apparently not. 
  So, it's good to know that "yum makecache" will do a more thorough 
rebuild of the metadata.

Hope this is useful to any of you running yum/rpm-based distros!

Gilbert E. Detillieux		E-mail: <gedetil at muug.mb.ca>
Manitoba UNIX User Group	Web:	http://www.muug.mb.ca/
PO Box 130 St-Boniface		Phone:  (204)474-8161
Winnipeg MB CANADA  R2H 3B4	Fax:    (204)474-7609

More information about the Roundtable mailing list